Once I thought the Mbox Mail for Mac doesn’t work in Lion. The reason is that when I use the same setting in Thurderbird, i can receive emails. This made me ensure the problem comes from the new Apple Mail 5. I dug into the protocol IMAP, learnt the commands used in it. After that I collected the message sent from Mail 5 and responded from the IMAP server. Great things happened! The reason Mbox Mail for Mac doesn’t work is Mail 5 used extra authentications during message exchanges, which could be ignored in the past. Therefore I start setting up server to modify the message exchanged to make the old server working for the new Mail. Making the fixing package may take some time. LOL

Use Mbox Mail for Mac Lion
With Apple Mail 5: Mbox Mail for Mac works on Lion with Apple Mail 5
With Thurderbird: Mbox Mail for Mac works on Lion with Thurderbird

20 thoughts on “Mbox Mail for Mac is actually working on Lion”

  1. Hi Michaels, so far i only made it work for single hotmail account. Technically I created another server as a middle man to replace the authentication commands from Mail 5. It works only for single because the authentication involves message digest which encrypted the login information and I could not crack it yet.
    Anyway, if you really need imap hotmail on Lion, I recommend you to install the Thurderbird Beta (the lastest one) which works on Lion. Do the same setting and you will probably get it works. =]

  2. Hello everyone. I have serious problem of accessing important folder on hotmail. Before it ws working fine but now the mbox does not work on Lion. Can you provide me detail because i am not too much familiar with technical stuff. I would appreciate it in simple instruction.

    Thanks in advance

  3. How do you get imap feature to work with hotmail in Thunderbird? Doesn’t seem to synchronize with server, just acting like pop-3

  4. However when I delete a message in Thunderbird it removes it from the inbox, but it doesn’t show up in the deleted messages folder (and it is set to move deleted messages to this folder). Also, it doesn’t move it to the deleted items on server but leaves it in inbox, so it re-appears in the Thunderbird inbox when synchronizing…..

    1. In Thurderbird, deleted items will be moved to Trash in default. You can change the setting in the settings of your mail account. Anyway, I tried again just now and it works. Maybe you could retry by sending yourself some mails. =]

  5. I have tried the default option, then changed to deleted items (which it where deleted messages are moved to on the server – trash is empty on the server). If I delete in windows mail on my PC, the message is moved to deleted messages in all clients and the server. If I delete in Thunderbird it is removed from the inbox, bot only locally on the mac and it does not turn up in deleted messages and it is kept in inbox on the server and pc. Therefore it synchronizes back to the inbox in thunderbird… Weird

    1. Just a theory, perhaps there is changes in permission setting of the mbox mail for mac after installing lion. Could you try right click and get info of “/Library/Application Support/FluentFactory/mBoxMail/mbox.dat”. Set “admin” right with “read and write” in the lowest section “Share & Permissions” and then retry deleting messages.

    2. If it is not okay, check if its parent folders (“/Library/Application Support/FluentFactory/mBoxMail”, “/Library/Application Support/FluentFactory”, etc) also have “admin” right with “read and write” too. =]

      1. Didn’t work… It may be of use to you to know, that if try to copy sent items to the sent folder on the server, it just tries to copy forever, but the message is sent. I disabled this feature, but the sent mail turns up in the sent folder on the server, and thus the PC, anyway (which is good, but strange)

      2. Also, if i right click a message in Thunderbird a choose send to deleted messages, then it does just that and it also turns up in deleted messages on the server and the windows mail client. That’s exactly what I want it to do when I delete a message, but it doesn’t even though it is set to “move to deleted messages”….

  6. I’ve sent a support e-mail to Fluent Factory as well. But, as someone else mentioned, it wasn’t exactly cheep. It’s actually very disappointing that the app hasn’t been updated in a while.

    Hope you find a solution. And, if you do find it before Fluent Factory, I’ll glad pay for it. You seem more engaged.

    Cheers.

  7. Now deleting items suddenly works from Thunderbird and synchronizes to server… It said that I could not connect to localhost, hit “try again”, then in must have connected and now it works

Leave a Reply

%d bloggers like this: